What's new

Image Tutorial How to build OEA 4.4 Images

Ten Below

SuperTux
Staff member
Admin
Moderator
Messages
8,792
Joined
Sep 9, 2014
Reaction score
7,314
Points
628
Since people are bored here is a way to pass lots of time & lose all your hair :lol:
These instructions are good for all OE-Alliance 4.4 images, Droid 7.0, ATV 6.4 ect.

Building Instructions
1 - Install packages on your buildserver
Code:
Please, Log in or Register to view codes content!
2 - Set your shell to /bin/bash.
Code:
Please, Log in or Register to view codes content!
When asked: Install dash as /bin/sh?
select "NO"

3 - Use update-alternatives for having gcc redirected automatically to gcc-8
Code:
Please, Log in or Register to view codes content!
4 - Repair g++ after gcc8 installation
Code:
Please, Log in or Register to view codes content!
5 - modify max_user_watches
Code:
Please, Log in or Register to view codes content!
6 - Add user openatvbuilder (Or name of your choice)
Code:
Please, Log in or Register to view codes content!
7 - Switch to user openatvbuilder
Code:
Please, Log in or Register to view codes content!
8 - Switch to home of openatvbuilder
Code:
Please, Log in or Register to view codes content!
9 - Create folder openatv
Code:
Please, Log in or Register to view codes content!
10 - Switch to folder openatv
Code:
Please, Log in or Register to view codes content!
11 - Clone oe-alliance git
Code:
Please, Log in or Register to view codes content!
12 - Switch to folder build-enviroment
Code:
Please, Log in or Register to view codes content!
13 - Update build-enviroment
Code:
Please, Log in or Register to view codes content!
14 - Finally you can start building a image
Code:
Please, Log in or Register to view codes content!
Have fun :hair:


ten.jpg


My own builds are created using OS Ubuntu 18.04.4
 

majz

Vuplus-Images Elite
Significant Contributor
Messages
414
Joined
Oct 8, 2014
Reaction score
292
Points
63
so will I
 

calypso

Vuplus-Images Elite
Member
Messages
65
Joined
Sep 16, 2016
Reaction score
21
Points
8
Would have given it a try but my Windows PC does not support Openembedded via Windows Subsystem for Linux (WSL). Besides my old Tower has now reached its last days. I wonder if mini pc's with linux can be used to build images.
 

Ten Below

SuperTux
Staff member
Admin
Moderator
Messages
8,792
Joined
Sep 9, 2014
Reaction score
7,314
Points
628
Would have given it a try but my Windows PC does not support Openembedded via Windows Subsystem for Linux (WSL). Besides my old Tower has now reached its last days. I wonder if mini pc's with linux can be used to build images.
When i started doing this i used a cheap vps for £5 a month running Ubuntu server, building took a little longer but it did the job. You don't need a hi spec machine.
 

ketmp

Vuplus-Images Elite
Significant Contributor
Messages
190
Joined
Feb 21, 2016
Reaction score
246
Points
43
If I start building from 4.4 branch as above, will this cause any problems if I still want to build anything from 4.3 that I use now on my VPS ?
 

levi45

Staff member
Super Moderator
Messages
376
Joined
Sep 15, 2017
Reaction score
1,167
Points
93
i did carry on building from 4.3 didn't had any issue , but better to get another opinion from master :ok:
 

Ten Below

SuperTux
Staff member
Admin
Moderator
Messages
8,792
Joined
Sep 9, 2014
Reaction score
7,314
Points
628
If I start building from 4.4 branch as above, will this cause any problems if I still want to build anything from 4.3 that I use now on my VPS ?
Sorry just revisited this thread & found your question months later lol, yes no problem switching branches but obviously if same team build you need to refresh.
i did carry on building from 4.3 didn't had any issue , but better to get another opinion from master :ok:
Master who?
:lol:
 

fallanuk

Vuplus-Images Elite
Member
Messages
50
Joined
Mar 12, 2016
Reaction score
89
Points
18
Hi Can this be used to create any image for any enigma2 boxes, As i have a Dinobox 4k+ and a Vu+ Ultimo 4k and a GigaBlue Quad Plus

thanks
 

pippomus

Member
Messages
2
Joined
Mar 18, 2020
Reaction score
1
Points
3
Hello, can be used ubuntu 20.04 to create this image, or you have to use the previous one 18.04 or 16.04
 

pippomus

Member
Messages
2
Joined
Mar 18, 2020
Reaction score
1
Points
3
Hello Ten Below
I followed your guide from the first post.
Using Ubuntu 18.04.4 operating system,
gives me several errors
can you give me explanations thanks
good afternoon
 

Ten Below

SuperTux
Staff member
Admin
Moderator
Messages
8,792
Joined
Sep 9, 2014
Reaction score
7,314
Points
628
Hello Ten Below
I followed your guide from the first post.
Using Ubuntu 18.04.4 operating system,
gives me several errors
can you give me explanations thanks
good afternoon
You will need to provide more info about what is failing.
 

Top Bottom