General VU+ Receiver Tutorials - Howto : Mipsel emu on Vusolo4k | vuplus-images.co.uk

General VU+ Receiver Tutorials Howto : Mipsel emu on Vusolo4k

Ten Below

Staff member
Admin
Joined
Sep 9, 2014
Messages
7,644
Likes
4,194
Points
528
Location
@vuplusimages
Website
vuplus-images.co.uk
#1
Howto : Mipsel emu on Vusolo4k

Guide & files by Lallone of Sat-universe.

Now it is possible to run some well known softcams from mips boxes on the Solo4K, using BH 3.0.x images.

First you need to install gnemul-qemu_mipsel-lib-all_bh.tgz (this file contains the libs needed from a mips box)
qemu --> is a a generic and open source machine emulator and virtualizer. Here it is used as a virtualiser, QEMU achieves near native performance by executing the guest code directly on the host CPU.

To install qemu you need to do the following:

telnet your vusolo4k, then type

Code:
opkg update
opkg install qemu
This will install the required packages

I've prepared a mgcamd example for you...

NOTE: So far CCcam does not work with this trick.

Next you will need to modify the camscript to reference your old softcam and make it to start using qemu with attached library, something similar to:


Code:
:
start:
/usr/bin/qemu-mipsel -L /usr/gnemul/qemu-mipsel/ /usr/bin/mgcamd_mipsel_1.38
stop:
killall -9 qemu-mipsel
If you find that some library files are missing, copy them from a mips box into the /usr/gnemul/qemu-mipsel folder.

mgcamd_1.38c attached and working
oscam mips (emu patched) working
CCcam so far not working

No others so far have been tested, so would be interesting to see if other emu's such as Gbox, Scam etc work.
 

Attachments

Joined
May 17, 2016
Messages
11
Likes
1
Points
3
#2
When I execute the "opkg install qemu" command I always have the following error:
Unknown package 'qemu'.
Collected errors:
* opkg_install_cmd: Cannot install package qemu.

Is this normal?

I've installed the qnemul-qemu-mipsel-lib-all_bh.tgz package and I can see the new gnemul folder under /usr

Thanks
 

Ten Below

Staff member
Admin
Joined
Sep 9, 2014
Messages
7,644
Likes
4,194
Points
528
Location
@vuplusimages
Website
vuplus-images.co.uk
#3
When I execute the "opkg install qemu" command I always have the following error:
Unknown package 'qemu'.
Collected errors:
* opkg_install_cmd: Cannot install package qemu.

Is this normal?

I've installed the qnemul-qemu-mipsel-lib-all_bh.tgz package and I can see the new gnemul folder under /usr

Thanks
Try opkg update then the command again but like your other thread i think you may need to change to BH image to get this working.
 
Joined
May 17, 2016
Messages
11
Likes
1
Points
3
#4
solved... I had to install the BH image and take the ipkg packages to OBH.
 
Joined
Jan 13, 2018
Messages
2
Likes
0
Points
1
Location
Germany
#5
hello what is with doscam it works with the trick?
 

Similar threads

Top