OpenVIX Update Announcements - OpenViX 5.2 released! | vuplus-images.co.uk

OpenVIX Update Announcements OpenViX 5.2 released!

Ten Below

Staff member
Admin
Joined
Sep 9, 2014
Messages
7,471
Likes
3,930
Points
528
Location
@vuplusimages
Website
vuplus-images.co.uk
Featured Thread #1
OpenViX 5.2 released!

vix.jpg

openvix-logo-150.png
OpenViX 5.2 is based on the OE-Alliance v4.2 core. You cannot perform an online update if you are currently on OpenViX 5.1.xxx or older.

You can download and then flash the new 5.2 image using Image Manager. You can still flash by USB if you prefer.

You can restore settings and plugins from OpenViX 5.1 series images after you have flashed the image. This will restore most things to how you had them before.

RESTORE PROCESS WILL NOT RESTORE PLUGINS THAT ARE NOT ON THE CURRENT PLUGIN SERVER. THESE MUST BE INSTALLED MANUALLY.


So what is different in OpenViX 5.2 then?
OpenViX 5.1 build 033 was the final build in the 5.1 series.

As with previous images, the main differences are core of the image or the OE (Open Embedded). This has undergone a lot of changes, updates and fixes. As a user you should not notice many differences between previous OpenViX 5.1 and OpenViX 5.2 (i.e. there are not many functional differences.)

Main OE Core changes

Based on Openembedded-Core Roko
The main packages and utilities have been updated:
Libc6
Openssh
Busybox
Samba
Openssl
Nfs Util
Dropbear
Bitbake
Gcc 6.3.0 Memleak fix

Known Image issues
Dreamplex - Some users in certain setup's may have issues.

Known Plugin/Receiver issues
Older receivers with lower amounts of memory struggle with downloading OpenTV EPG data using Cross EPG downloader. Use a swap file in such cases.
Some 3rd party plugins may not be currently compatible with OE-A 4.2x core, streaming plugins may require their respective author's to add dependencies for GST 1.xx.
HbbTV not working for all receivers. Please raise issue with respective Manufacturer.

Button Mappings

Short Red** & *** - Show current channel EPG info (ViX Single EPG).
Long Red ** & *** - Sort single EPG info when in channel list.
Short Green** & *** - Timers.
Long Green*** - AutoTimer Timers.
Short Yellow*** - EPG Search.
Long Yellow*** - Instant IMDB Database search on the current programme.
Short Blue - Extensions.
Long Blue*** - Plugins Menu.
EPG - Opens ViX EPG.
Left/Right** - Opens ViX QuickEPG.
Left/Right** - Opens ViX QuickEPG.
Up/Down** - Open Full Screen Channel List.
Long Up/Down - Open PIP list on boxes that support PIP.
TV Button** - Open Full Screen Channel List.
Long TV Button - Open Bouquets List.
** Can be changed in ViX Menu
*** Can be turned off in ViX Menu


Special Thanks


  • Rytec, doglover and all the teams that host EPG feeds for EPG Importer, for their continued support.
  • All developers for their plugins used in the feeds of this image.
  • All of the ViX Beta team for their hours of testing and dedication on improving the image.
  • All those who have submitted patches/fixes
  • To all who have submitted translation work for OpenViX.
  • Huevos for his work on blindscan and ABM.
  • Peter de Jonge, abu baniaz & Huevos for their work with Andyblac to improve ABM.
  • Rob van der Does, rossi2000, abu baniaz and Huevos for OpenViX skins.


Notes

Receivers no longer supported in 5.2

Due to limited resources some end of life models will not be built in version 5.2. If you want to use OpenViX with these receivers please use version 5.1 or build version 5.2 yourself. The following is a list of the receivers not supported in version 5.2:
  • Technomate TM-Single.
  • Technomate TM-Nano-OE.
  • Technomate TM-2T.
  • TM-Nano-2T.
  • Mutant 500C.
  • Octagon SF8.
  • Octagon XP1000+.


Receivers no longer supported in 5.0
Due to limited resources some end of life models will not be built in version 5.0. If you want to use OpenViX with these receivers please use version 4.2 or build version 5.0 yourself.
The following is a list of the receivers not supported in version 5.0:

  • Gigablue SE Plus
  • Gigablue UE Plus
  • Golden Interstar LX1 & LX2
  • Media Link Ixuss Zero
  • Miraclebox Mini
  • Opticum DVBC-1
  • Spycat
  • Venton HDx
  • Xtrend ET4x00
  • Xtrend ET5000
  • Xtrend ET6x00



Receivers no longer supported in 4.0
Some receivers that lack resources (only have 333MHz CPU, insufficient flash, lack driver support, etc) will not be built in version 4.0. If you want to use OpenViX with these receivers please use version 3.2 or build version 4.0 yourself. The following is a list of the receivers not supported in version 4.0:


 

Attachments

Joined
Oct 9, 2017
Messages
3
Likes
1
Points
3
Location
UK
#3
what is ftp user an pass as cant login to ftp?
 

Top