Custom / Unofficial Build - To my compiler friends | vuplus-images.co.uk

Custom / Unofficial Build To my compiler friends

LandRocket

V.I.P Member
Joined
Apr 5, 2016
Messages
100
Likes
24
Points
28
#1
I'm just wondering if anyone here has checked out the 4.1 branch from the GIT?

The reason I ask is because I've been able to make a solo4k image for openatv, but I can't seem to get solo4k to build for openbh?

Keeps failing and complaining about "No package 'sigc++-1.2 found'

I've installed the 2 "libsigc++-1.2" packages that I found in apt, but it makes no difference. It needs a more expert opinion....

upload_2017-4-27_9-1-25.png

Many thanks :)
 

Ten Below

Staff member
Admin
Joined
Sep 9, 2014
Messages
7,345
Likes
3,671
Points
528
Location
@vuplusimages
Website
vuplus-images.co.uk
#2
I'm just wondering if anyone here has checked out the 4.1 branch from the GIT?

The reason I ask is because I've been able to make a solo4k image for openatv, but I can't seem to get solo4k to build for openbh?

Keeps failing and complaining about "No package 'sigc++-1.2 found'

I've installed the 2 "libsigc++-1.2" packages that I found in apt, but it makes no difference. It needs a more expert opinion....

View attachment 17310

Many thanks :)
Try extracting & adding these to your sources folder, i did compile the same image just last month so should work.
 

Attachments

danny187

Super Moderator
Joined
Feb 23, 2016
Messages
989
Likes
242
Points
58
#3
Mine failed on that last night actually for openBH.

Have had Vix and BH furtehr than that prior and then failed on

missing vix.py.pot and same for openbh.

Well did last week lol
 

danny187

Super Moderator
Joined
Feb 23, 2016
Messages
989
Likes
242
Points
58
#4
I lready had in sources, but overwrite and it failed.

configure: WARNING: using cross tools not prefixed with host triplet
| checking pkg-config is at least version 0.9.0... yes
| checking for GSTREAMER... yes
| checking for BASE... no
| configure: error: Package requirements (freetype2 fribidi gstreamer-1.0 gstreamer-pbutils-1.0 libdvbsi++ libpng libxml-2.0 sigc++-1.2 libssl libcrypto) were not met:
|
| No package 'sigc++-1.2' found
|
| Consider adjusting the PKG_CONFIG_PATH environment variable if you
| installed software in a non-standard prefix.
|
| Alternatively, you may set the environment variables BASE_CFLAGS
| and BASE_LIBS to avoid the need to call pkg-config.
| See the pkg-config man page for more details.
| NOTE: The following config.log files may provide further information.
| NOTE: /home/oeimages/build-enviroment/builds/openbh/release/vuuno4k/tmp/work/vuuno4k-oe-linux-gnueabi/enigma2/enigma2-1.1+gitAUTOINC+3137bfd486-r4/git/config.log
| ERROR: configure failed
 

LandRocket

V.I.P Member
Joined
Apr 5, 2016
Messages
100
Likes
24
Points
28
#5
I'm going to try one of the other DISTROs, as I'm starting to think this is just down to openbh not being ready.....

Looking at the DISTROs from oe-alliance/oe-alliance-core/tree/4.1/meta-oe/conf/distro I see that a lot of them mention the switch to libsigc2.0

Well, with the downloaded enviroment for the openbh distro I went into ~/oealliance/build-enviroment/builds/openbh/release/vusolo4k/tmp/work/vusolo4k-oe-linuxgnueabi/enigma2/enigma2-1.1+gitAUTOINC+3137bfd486-r4/git and edited configure.ac line 42 to read sigc++-2.0 instead of 1.2; now it goes further but down the line it fails because of issues with sigc/slot.h

I did notice that if you look in ../usr/include that there is only header files for sigc2; so I'm suspecting that it's purely that the openbh build can't be compiled yet as it's still a work in progress......

I'm going to carry on messing about with it, as it keeps me out of trouble.... :)
 

danny187

Super Moderator
Joined
Feb 23, 2016
Messages
989
Likes
242
Points
58
#6
I'm going to try one of the other DISTROs, as I'm starting to think this is just down to openbh not being ready.....

Looking at the DISTROs from oe-alliance/oe-alliance-core/tree/4.1/meta-oe/conf/distro I see that a lot of them mention the switch to libsigc2.0

Well, with the downloaded enviroment for the openbh distro I went into ~/oealliance/build-enviroment/builds/openbh/release/vusolo4k/tmp/work/vusolo4k-oe-linuxgnueabi/enigma2/enigma2-1.1+gitAUTOINC+3137bfd486-r4/git and edited configure.ac line 42 to read sigc++-2.0 instead of 1.2; now it goes further but down the line it fails because of issues with sigc/slot.h

I did notice that if you look in ../usr/include that there is only header files for sigc2; so I'm suspecting that it's purely that the openbh build can't be compiled yet as it's still a work in progress......

I'm going to carry on messing about with it, as it keeps me out of trouble.... :)
Messing is good, the amount of times I have killed one of my OpenPLI build enviroments, recent one on trying get Kodi 17 installed.

haha
 

LandRocket

V.I.P Member
Joined
Apr 5, 2016
Messages
100
Likes
24
Points
28
#7
OK well now I just feel I'm missing something obvious. vix build fails with same message so it's got to be my build-server.

What am I missing folks? :(
 

danny187

Super Moderator
Joined
Feb 23, 2016
Messages
989
Likes
242
Points
58
#8
OK well now I just feel I'm missing something obvious. vix build fails with same message so it's got to be my build-server.

What am I missing folks? :(
Mines the same, I went to install some stuff, said I had some errors, removed some and then couldnt reinstall lmao

But I can build

OpenATV 6.1 fine on 4.1 branch
OpenVIX 5.0 on 4 branch, although when compiled after a while its gets tuck on restart gui and I need telnet killall -9 enigma2 lol
OpenATV 6.0 on 4
OpenBH as above
OpeNPLi 5.0

Only Vix and BH fails on 4.1, so maybe they dont have it complete on them distros at the mo
 

danny187

Super Moderator
Joined
Feb 23, 2016
Messages
989
Likes
242
Points
58
#9
Also I cant include GSTPLAYER like I did prior on the OE inmage also.
 

LandRocket

V.I.P Member
Joined
Apr 5, 2016
Messages
100
Likes
24
Points
28
#10
Your challenge awaits you lol

Modern day ghostbusters:
./configure
are you a god? : n
make
make install
Install failed.... replacing hello world with taking over world
 

LandRocket

V.I.P Member
Joined
Apr 5, 2016
Messages
100
Likes
24
Points
28
#11
@danny187 really glad you confirmed we're in the same position.

I'm wondering if there's dependencies from the 4.0 branch that I didn't bring in since I set up a new environment for 4.1?

Sorry if that sounds dumb but my unix/Linux experience came from SCO V when you just used WordPerfect, then from compiling IRC services and then to debugging compile errors so I've still got my L plates IMO.

Learn every day :)
 

danny187

Super Moderator
Joined
Feb 23, 2016
Messages
989
Likes
242
Points
58
#12
@danny187 really glad you confirmed we're in the same position.

I'm wondering if there's dependencies from the 4.0 branch that I didn't bring in since I set up a new environment for 4.1?

Sorry if that sounds dumb but my unix/Linux experience came from SCO V when you just used WordPerfect, then from compiling IRC services and then to debugging compile errors so I've still got my L plates IMO.

Learn every day :)
Myself also, I have installed so much shite last week or so, for other things, I have no clue if any good.

I had zero experience of even a command prompt or anything until I become mod on here and @Ten Below and I chatted and I tried it and he helped me loads.

even now, I am a trial and error man, have zero background in any of this, or the platforms like, I should learn some sort of coding really but struggle to study tbh.
 

LandRocket

V.I.P Member
Joined
Apr 5, 2016
Messages
100
Likes
24
Points
28
#13
Myself also, I have installed so much shite last week or so, for other things, I have no clue if any good.

I had zero experience of even a command prompt or anything until I become mod on here and @Ten Below and I chatted and I tried it and he helped me loads.

even now, I am a trial and error man, have zero background in any of this, or the platforms like, I should learn some sort of coding really but struggle to study tbh.
CLI is like p0rn lmao.....

The vi commands I learnt 28 years ago still work to this day.... that's good going.. !wq

I'm really glad I managed to bring some of that stuff into 2017....

I reckon we need a developer sub-forum..... so I can take the p155 when you forgot to install gcc :p
 

danny187

Super Moderator
Joined
Feb 23, 2016
Messages
989
Likes
242
Points
58
#14
CLI is like p0rn lmao.....

The vi commands I learnt 28 years ago still work to this day.... that's good going.. !wq

I'm really glad I managed to bring some of that stuff into 2017....

I reckon we need a developer sub-forum..... so I can take the p155 when you forgot to install gcc :p
That makes no sense to me haha.

I am not a developer, no way would I can myself that, I am more someone who messes about with stuff cos I get bored and need to actually keep an image on my box for more than a day lol
 

LandRocket

V.I.P Member
Joined
Apr 5, 2016
Messages
100
Likes
24
Points
28
#15
A whole day?

There's 24 hours in a day. Sleep for 8 = 16. 2 hour compile + 1 hour testing =
3. 16/3= 5 with 1 remain. That 1 hour = watching Tv time lol

Slacker lmao
 

LandRocket

V.I.P Member
Joined
Apr 5, 2016
Messages
100
Likes
24
Points
28
#16
I did post through to the OpenBH forums, but still no responses..... and unfortunately no progress to report yet :(
 

danny187

Super Moderator
Joined
Feb 23, 2016
Messages
989
Likes
242
Points
58
#17
I made a new branch 4.0, if do make update, I now get same error as branch 4.1, was failing on something else also.
 

LandRocket

V.I.P Member
Joined
Apr 5, 2016
Messages
100
Likes
24
Points
28
#18
I've managed to compile OpenBH for Solo4K and Ultimo4K today (20170504) at 3am GMT on 4.0 branch. Still same issue with sigc++-1.2 on 4.1 branch

The only thing I do know is that when I reinstalled my build-server, I got an error about needing curl, which can be installed with a simple "sudo apt-get install curl"
 

danny187

Super Moderator
Joined
Feb 23, 2016
Messages
989
Likes
242
Points
58
#19
I've managed to compile OpenBH for Solo4K and Ultimo4K today (20170504) at 3am GMT on 4.0 branch. Still same issue with sigc++-1.2 on 4.1 branch

The only thing I do know is that when I reinstalled my build-server, I got an error about needing curl, which can be installed with a simple "sudo apt-get install curl"
I have a branch 4.0 which is fine, I have a branch 4.0 which is up to date as today and fails lol.

Not that I am fussed, was mainly for OpenPLi 5.0 but that as much I love it has some limitations.
 

Top